You are not logged in or registered. Please login or register to use the full functionality of this board...

Aqua hot issues
#1
thought I would pass on some aqua hot knowledge. One of the copper pipes above the middle aqua hot motor had broke, it was the same spot it had broke 3 months ago and Newell had repaired. The leaking fluid from the pipe leaked onto the engine preheat pump. This caused my preheat light to come on and off at random times. Newell currently doesn't have any of the pumps in stock so we shoot of the valves at the back of the coach. One was leaking so we replaced it.

Another symptom of the pre heat pump shorting out was it caused the relays in the aqua hot to chatter. 

So just some issues I had thought I would pass on.
Marc Newman
Formerly Newell 422, 507, 512 701


#2
Marc,

All, I mean ALL, Aqua Hot parts are in stock at Roger Berke's website. Get on the Aqua Hot forum for questions about what part(s) you might need and Roger will fix you up right away. Parts ordered by noon in the next few days (before he leaves Texas for the west coast) will arrive the day. Modest discount, no sales tax and no shipping charge.

I do not know what Newell did for the repair but I have never seen a pipe above the pumps fail. Something might be allowing vibration movement that should not be there (just a guess).
Rudy Legett
1995 Foretravel U320
M11 400hp Allison 4060R
Factory Authorized Aqua Hot Repair Center
Greater Houston Area
#3
Agreed , we will see how this holds up. I'll check the website for a new pump.
Marc Newman
Formerly Newell 422, 507, 512 701




Forum Jump:


Users browsing this thread: 1 Guest(s)