You are not logged in or registered. Please login or register to use the full functionality of this board...

Front aquahot heater
#1
Well I was still having an intermittent problem with the front heater not coming on every time. When I would touch the relay on the aquahot it would start. So after reading Steve Magown's post where he had a bad relay socket I looked at mine and it looked discolored so I went ahead and changed all 3. Easy to change out, just pull the release and they pop off the DIN rail. Then snap on the new sockets and wire it up.
But it still didn't work! So stuck my head back in the compartment, wiggled the relay and it started up. Finally figured out that one of the wires from the mini-relay 30amp (small black cube on the side near the terminal block) was loose. Pulled it off and tightened the connector. Now it works every time!
Forest & Cindy Olivier
1999 Foretravel 36' U320
former 1998 Newell 45' 2 slide #486 

former 1993 Newell 39' #337 
2011 Chevy Tahoe 

2010 Silverado w/ RZR 570LE
#2
nice fix! Gotta love the scratch your (head) then just kick-it!
See All You Can!
Before Its Gone!Big Grin
#3
Hey congrats on selling your coach!
What you gonna do now? Looking for another one or just sit home all summer & sweat?
Forest & Cindy Olivier
1999 Foretravel 36' U320
former 1998 Newell 45' 2 slide #486 

former 1993 Newell 39' #337 
2011 Chevy Tahoe 

2010 Silverado w/ RZR 570LE
#4
Its been quite a few years since I've sat home and sweat? However this winter the front porch looks pretty good!
Actually Forest, I am quite feed-up with louisiana... who knows..

Also if anyone needs a coach delivered anywhere....I will roll for the cost of expenses only!!

"I'm Easy, but not Cheap!"
See All You Can!
Before Its Gone!Big Grin


Forum Jump:


Users browsing this thread: 1 Guest(s)