You are not logged in or registered. Please login or register to use the full functionality of this board...

salt lake and back
#1
darlene and i did a trip to salt lake city and back this past week.  got back last nite.  about 1400 miles.  averaged 7.1 mpg.   lots of summits and corresponding ups and downs.  so that seems about right.  

coach purred like a kitten.  only issue i had is the starting batteries seemed weak.  no big deal as i used the coach batteries to augment them.  

we got home last nite and unloaded.  parked out on the rv pad next to the shop so i could hose it down this morning and clean the engine compartment and check the batteries.  

the batteries load tested fine....but lots of corrosion on the terminals.  the worst one was the positive on the second battery.  in takng off the cables, the 3/0 cable pulled out of the crimped terminal.  so that was my problem.  so i dropped the two short jumers that go between the batteries off at wickenburg napa and they are making me two new ones i will pick up friday morning.  

i should be good then.  

later

tom
2002 45'8" Newell Coach 608  Series 60 DDEC4/Allison World 6 Speed HD4000MH

Reply
#2
Tom,

I had same symptoms but my issue turned out to be the grounding post by the engine. Totally corroded. I actually had two posts and spun the top off of one when I tried to clean up. (A fellow guru came to my rescue )

So...as long as you are looking at cables...look at the ground.

bill
Bill Johnson
2003 Newell #653 Quad Slide Cat C-12 engine with Motorcycle lift 
2011 Jeep Wrangler, 2018 BMW 1200GS Adventure Motorcycle
Auburn, Alabama
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)