You are not logged in or registered. Please login or register to use the full functionality of this board...


[-]
Tags
generator

Gen set issues
#1
Gen set will start but dies when cold after 10 seconds.
Fuel shutoff Solenoid not locking in completely. Intermittent issue.

Anyone have a run ckt one line diagram or wiring diagram.
Coach 267 1991
Kohler 12.5
MODEL: 12.5 CC067 -RV
SER:        251450
SPEC:     135014


BOB BLAIR
1991 44'
COACH 267
#2
I had a similar problem on my ‘78 with the 12.5. There was a glass fuse on the back side of a panel in the control box. You can’t see it from the front . The holder was corroded.
1993 Newell 45' 8V92,towing an Imperial open trailer. FMCA#232958 '67 Airstream Overlander 27' '67GTO,'76TransAm,'52Chevy panel, 2000 Corvette "Lingenfelter"modified, '13 Grand Cherokee.
#3
Any one lines for start / run ckt?
#4
Possibly may be the auto fire extinguisher system. If pressure is low it will kill generator. There is a work around with a jumper wire. But be aware that that is defeating a valuable safety system. Another possibility would be plugged fuel filter.
#5
Robert, there are several items to check.  First let me explain the operation of the solenoid.  There are two coils inside, one for pull in and the other for hold in.  On most Kohler sets, the pull in is tied to the starter motor.  The pull in has quite a bit of strength and draws a lot of current so, it can’t stay energized long or else it will fail.  After the iron core is pulled inside, the hold in keeps it in.

My first reading of your problem leads me to think the iron core and the inside of the coil housing is dirty so first, I would clean and lube with dry graphite or molybdenum disulfide.  It needs to slide freely.  Check linkage adjustment to be sure the core will bottom out inside the coil housing and not be stopped by the end limit of the injector pump lever stop.

The hold in ,as someone mentioned, is in series with a pressure switch on the fire extinguisher.  Be sure that switch is closed and there is power on the hold in circuit.   If there is no power on the hold in, as someone said, check the fuse and for corrosion of connections.   Also, if your generator is not making voltage, the control circuit will not power the hold in.   The hold in power is the same as the lift pump power.   And finally, make sure you have fuel flow which can be determined if the engine will stay running if you manually hold the iron core in.

It is a process of elimination, good luck.
Gordon Jones
2000-45'-2slide-#567
#6
Robert, I understand your statement about pushing a little and it starts right up.   I’m sure your core and coil tube need cleaned.  Follow my instructions and you’ll be fine.
Gordon Jones
2000-45'-2slide-#567


Forum Jump:


Users browsing this thread: 1 Guest(s)