You are not logged in or registered. Please login or register to use the full functionality of this board...

Aquahot for dummies?
#1
I have a Low Tank cutoff (red light) and a low temp cutoff green light both illuminated. I went to CW today to buy some boiler antifreeze, topped off the tank (main) and made sure the overflow bottle had an adequate  level of coolant. After making sure everything was topped off, red light still on and I get no hot water. I checked all the fuses (good) reset the main breaker, check. NOTHING??

She will not fire with elec. or diesel, I am assuming that as long as that red light is on it will stay in safe mode. Is there a reset switch?? I've looked at the manual and it says "the light will reset itself once fluids are at the appropriate levels"

Scratching my head. Any ideas on how to get that light out?

TIA

Carthan
home: Sacramento Area
current rig 05 #746 quad slide 2000i
01 National Islander
Toad 10 Avalanche
#2
I'm not familiar with the newer models of Aquahot but did you pull the main fuse to remove 12 volt DC power or just the 120/220 AC breaker? I would think the AC voltages would only affect the electric elements but the DC voltage would shut down the controller and should reset it.
Try pulling the main 12 volt DC power for a few minutes and see if that works. If not call Rudy, he is extremely helpful.
Rudy Legett at 713-818-3234
Forest & Cindy Olivier
1999 Foretravel 36' U320
former 1998 Newell 45' 2 slide #486 

former 1993 Newell 39' #337 
2011 Chevy Tahoe 

2010 Silverado w/ RZR 570LE
#3
Look around on the black box control unit for a reset button.
Richard and Rhonda Entrekin
99 Newell, 512
Subaru Outback Toad
Inverness, FL (when we're home Cool )
#4
Sounds like failed "Low Tank Sensor". Unplug harness to the sensor and jumper the harness together, I use a 5, 10 or 15 amp car blade fuse. But any jumper will work.

Art Twaddell is factory authorized service on the California central coast and very good his phone is 8 zero 5 7 one 2 9449

What model heater do you have in that 2000 coach?
Rudy Legett
1995 Foretravel U320
M11 400hp Allison 4060R
Factory Authorized Aqua Hot Repair Center
Greater Houston Area
#5
Thanks guys,
It is model AHE-120-04X
@Richard, that's the button I want to find ?
@Trainer, I'll go see if the status changed on its own overnight. I'll put in a call. The DW isn't feeling the cold showers right now. Not too happy
home: Sacramento Area
current rig 05 #746 quad slide 2000i
01 National Islander
Toad 10 Avalanche
#6
Trainor, Correct, I jumped them together and the light went out. Ill call Art and see what it'll take to change the float sensor.
home: Sacramento Area
current rig 05 #746 quad slide 2000i
01 National Islander
Toad 10 Avalanche


Forum Jump:


Users browsing this thread: 1 Guest(s)